Excel: Formatting
Table of Contents

Introduction ................................................................................................................................................. 3
1-A Formatting Can Enhance Your Excel Spreadsheet ................................................................. 4
1-B Selecting a Range .......................................................................................................................... 5
1-C The Formatting Toolbar ................................................................................................................. 7
2-A Text Formats .................................................................................................................................... 9
2-B Text Alignment, Wrapping and Rotation ..................................................................................... 10
2-C Cell Borders and Backgrounds ...................................................................................................... 11
3-A Number Formats ........................................................................................................................... 12
4-A Using the AutoFormat Feature .................................................................................................... 18
4-B Conditional Formatting ................................................................................................................. 19
Resources .................................................................................................................................................. 21

Excel: Formatting
Introduction

Objectives
The aim of this course is to show you how to:
- Use formatting to enhance your Excel worksheet.
- Work with text attributes and alignments.
- Effectively use colors, patterns and borders.
- Specify number formats.
- Make use of the AutoFormat feature.
- Use conditional formatting.

The software described is Excel 2002 running on Windows XP.

Prerequisites
You should have a basic working knowledge of Microsoft Excel, including how to enter data, work with cells and ranges, and navigate a worksheet. You should also be familiar with the Windows XP desktop and with general concepts of manipulating windows such as menus, scrollbars and dialog boxes.

Key:
Caution ⚠️
Cool Tip 🔥
Please Note 🍃
I. How Formatting Can Enhance Your Excel Worksheet

Formatting changes the way that numbers and text appear in a worksheet. You can use Excel formatting features to make a worksheet more attractive, to make it easier to read, or to emphasize key data. You can accomplish this by using different colors and fonts for the cell contents, adjusting column and row attributes, and altering the way numeric data is displayed. Formatting changes only the appearance of the worksheet, and not the value of the data.

In the example below, you can see that basic formatting makes your data easier to read and your worksheet more attractive.

![Worksheet with no formatting](image1)

![Same worksheet formatted](image2)
2. Essential Review: Selecting a Range

Before you can apply formatting changes to your data, you need to select the cell or range of cells to which you wish to make the change.

To select a range of cells:
With the mouse, point to the center of the cell in one corner of the range (the mouse will look like an empty cross ( ), then do one of the following:
• Press and hold the mouse button while dragging to the opposite corner of the range; release the mouse button.
• Press and hold the [Shift] key and click on the opposite corner of the range to select all cells in between.
• Press and hold the [Shift] key and press the arrow keys to highlight the range.

Selecting (Highlighting) an entire Row, Column, or Sheet

• To select an entire Row, click on the Row Heading (the number at the left of the row).

• To select an entire Column, click on the Column Heading (the letter at the top of the column).
• To select an entire sheet, click in the gray box to left of Column Heading A and above Row Heading 1.

![Figure 2-3: Select entire sheet](image)

Be cautious of applying formatting such as borders to an entire sheet, this format will be applied to them infinitely. A printout of such would include all the borders, producing pages and pages of unwanted lines.

Adjacent vs. Non-adjacent Ranges

In Excel, you can select more than one range at the same time. However, those ranges do not have to be adjacent. To select a group of separate (non-adjacent) ranges that you want to affect at the same time:

- **Windows:** Highlight the first continuous range, then hold down the [Control] key and select additional non-adjacent cells and cell ranges, these must be non-adjacent cells.
- **Macintosh:** Highlight the first continuous range, then hold down the [Command] key and select additional non-adjacent cells and cell ranges.
### 3. The Formatting Toolbar

The easiest way to make basic formatting changes is by using the formatting toolbar. The Formatting toolbar allows you quick access to the most commonly used formatting options available in Excel.

If you don’t see the Formatting toolbar, click View > Toolbars > Formatting.

<table>
<thead>
<tr>
<th>Toolbar Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Arial</strong> 10</td>
<td>Determines Font type and Font size.</td>
</tr>
<tr>
<td><strong>B I U</strong></td>
<td>Applies font attributes: bold, italic, underline.</td>
</tr>
<tr>
<td><strong>Align Text</strong></td>
<td>Aligns text in the cell: left, center, right, centers text across columns and combines two or more selected adjacent cells into one cell.</td>
</tr>
<tr>
<td><strong>Number Format</strong></td>
<td>Applies number formatting: Currency style, Comma Style, Percent Style, Increase/Decrease Decimal.</td>
</tr>
<tr>
<td><strong>Indent</strong></td>
<td>Decreases/Increases Indent.</td>
</tr>
<tr>
<td><strong>Colors</strong></td>
<td>Adds/changes background and text colors.</td>
</tr>
<tr>
<td><strong>Borders</strong></td>
<td>Adds lines or borders</td>
</tr>
</tbody>
</table>

**Scenario:**
You’ve been working successfully with an Excel spreadsheet to keep your department’s office supply expenditures organized. In an upcoming meeting you’ll distribute the spreadsheet and would like to make it look more professional and easier to read. In this activity you will use the Formatting toolbar to apply basic formatting.

**Activity**

**Format Data with the Formatting Toolbar**

1. Open the file Excel_Formatting.xls from the Excel folder on the desktop.
2. Select the B2 in order to select the spreadsheet title, "January’s Office Supply Expenditures".
3. Using the drop down menu in the Formatting toolbar, change the font to Times New Roman and the font size to 16.
4. Select the range A2:H2.
5. Click the **Merge and Center** button. This will merge the cells in that range into one cell and center your text.
6. With the cell A2 highlighted, click the **Fill Color** button drop-down arrow on the Formatting toolbar (refer to Figure 3-1) and select fill color Dark Blue.
7. Click the **Font Color** button drop-down arrow on the Formatting toolbar (refer to Figure 3-1) and select font color White.

![Figure 3-1: Fill Color and Font Color Format](image)

8. Select Column G and click on the **Percent Style** button to display the column’s contents as percentages of 100.
4. Text Formats

Font
A font is the name for a collection of characters (letters, numerals, symbols, and punctuation marks) with a similar, specific design. The font size is the physical size of the text, measured in units called points. The default font in Excel is 10 point Arial. You can change the font, the size or both of any worksheet entry or section by using the Format command on the menu bar or by using the Formatting toolbar.

To change the font:
1. Select desired cell or range.
2. In the **Font** box on the Formatting toolbar, use the dropdown arrow to select the font type you want.
3. In the **Font Size** box, use the dropdown arrow to select the font size you want.

Text Attributes
Attributes are styling formats such as **bold**, **italics**, underlining, and **color** that you can apply to affect the way text and numbers look in a worksheet.

Less is more! Overuse of any formatting attribute can be distracting and make a workbook less readable.

You can use the Formatting Toolbar buttons or the **Format Cells Window** to change text attributes.

1. Select the cells you wish to format.
2. On the Format menu, choose Cells.
3. Click on the Font tab and change desired settings.
4. Click OK.

*Figure 4-1: Font Formatting*
**5. Text Alignment, Wrapping and Rotation**

You can change the alignment of labels and values in cells to be left, right or center.

To position data in a cell:

1. Select the cells you want to reposition.
2. On the Formatting toolbar, click the appropriate button.
   - Click **Align Left**, to align text to the left.
   - Click **Center**, to center text.
   - Click **Align Right**, to align text to the right.

To align data at the top, center, or bottom of a cell:

1. On the **Format** menu, click **Cells**, and then click the **Alignment** tab.
2. In the **Vertical** box, click the option you want.

The data in a column is often very narrow while the label for the column is much wider. Instead of creating unnecessarily wide columns or abbreviated labels, you can use text wrapping or rotate text and apply borders that are rotated to the same degree as the text. Borders are applied to the edges of the cells, which are rotated to the same degree as the rotated text.

To display multiple lines of text within a cell:

1. Select the cells you want to format.
2. On the **Format** menu, click **Cells**, and then click the **Alignment** tab.
3. Under **Text control**, select the **Wrap text** check box.

To rotate text in a cell:

1. On the **Format** menu, click **Cells**, and then click the **Alignment** tab.
2. In the **Orientation** box, click a degree point, or drag the indicator to the angle you want.

To display text vertically from top to bottom, click the vertical **Text** box under **Orientation**.

To restore the default alignment, select the cells, click **Cells** on the **Format** menu, and then click the **Alignment** tab. In the **Horizontal** box, click **General**.
6. Cell Borders and Backgrounds

You can use colors, patterns and borders to enhance the overall appearance of a worksheet and to make it easier to read. You can apply borders to all the cells in a worksheet or only to selected cells to call attention to individual cells or a range of cells. This is especially useful if you are going to print your worksheet because, by default in Excel, the light gray cell gridlines don’t appear when you print a worksheet document.

To apply a border around a range:

1. Select the range of cells on the page to which you want to add a border.
2. Click the Borders button on the toolbar at the top of the screen.

Select a border style from the options that are displayed. In Figure 6-1, the All Borders option is selected - this places a single line around all sides of all of the selected cells.

To draw in a border, a border grid, or choose a line color, select Draw Borders from the dropdown menu.

To apply cell shading:

1. Select the cells you want to apply shading to or remove shading from.
2. To apply a different color, click the arrow next to Fill Color, and then click a color on the palette.

To shade cells with a pattern:

1. On the Format menu, click Cells, and then click the Patterns tab.
2. To include a background color with the pattern, click a color in the Cell shading box.
3. Click the arrow next to the Pattern box, and then click the pattern style and color you want.

To remove shading:
On the Formatting toolbar, click the arrow next to Fill Color, and then click No Fill.
7. Number Formats

You can use number formatting to change the appearance of numbers, including dates and times, without changing the number behind the appearance. The number format does not affect the actual cell value that Microsoft Excel uses to perform calculations. The actual value is displayed in the formula bar. Excel contains many built-in number formats you can choose from. To list them, click Cells on the Format menu, and then click the Number tab.

To apply a number format:

1. Select the cells you want to format.
2. On the Format menu, click Cells, and then click the Number tab.
3. In the Category list, click the appropriate category.
5. Click OK.

Figure 7-1: Number Formatting

Built-in number formats

- **General**
  - General format cells have no specific number format. Cell contents are displayed the way you entered them.
  - If the cell is not wide enough to show the entire number, rounds numbers with decimals and uses scientific notation for large numbers.

- **Number**
  - Used for general display of numbers. Two decimal places are shown as the default.

- **Currency**
  - Used for general monetary values. Numbers are displayed with two decimal places and a dollar sign ($).

- **Accounting**
  - Same as currency, but lines up the currency symbols and decimal points in a column.

- **Date**
  - Displays date and time serial numbers as date values. Default is mm/dd/yyyy.
Microsoft Excel stores dates as sequential numbers which are called serial values. By default, January 1, 1900 is serial number 1, and January 1, 2008 is serial number 39448 because it is 39,448 days after January 1, 1900. Excel stores times as decimal fractions because time is considered a portion of a day.

As values, dates and times can be added, subtracted, and used in other calculations. View a date as a serial value and a time as a decimal fraction by changing the format of the cell that contains the date or time to General format.

- **Time**
  - Displays data and time serial numbers as time values. Default is hh:mm:ss AM/PM.

- **Percentage**
  - Multiplies the cell value by 100 and displays the result with a percent symbol (%) and two decimal places.

- **Fraction**
  - Displays as a fraction. Default is up to one digit (1/4).

- **Scientific**
  - Displays as a scientific format. Default is two decimal places.

- **Text**
  - Treated as text even when a number is in the cell. The cell is displayed exactly as entered.

- **Special**
  - Used for tracking list and database values.
    - Zip Code
    - Phone Number
    - Social Security Number

- **Custom**
  - Used to create a custom number format.
  - If your desired number format is similar to one you can find in the dialog, select it, and then click on the Custom category. The chosen number format will be displayed in an edit box, where you can adjust it as needed.
To create a custom number format:

1. Select the cells you want to format.
2. On the Format menu, click Cells, and then click the Number tab.
3. In the Category list, click a category that is similar to the one you want, and then set its built-in formats to be similar to the ones you want. (You will not alter the built-in format; you’ll be creating a copy to customize.)
4. In the Category list, click Custom.
5. In the Type box, edit the number format codes to create the format you want.

To correct a ###### error:
When a column is not wide enough to display its contents, number signs display indicating the error. To resolve, do one of the following:

- **Increase the width of the column**
  o Select the column, point to Column on the Format menu, click Width, and then enter a number.

- **Shrink the contents to fit the column**
  o Select the column, then on the Format menu, click Cells, click the Alignment tab, and then select the Shrink to fit check box.

- **Apply a different number format**
  o In some cases, you can change the cell’s number format to make the number fit within the existing cell width. For example, decrease the number of decimal places after the decimal point.

Figure 7-2: ###### error
Scenario:
Your worksheet is looking better but it could use some additional formatting. In this activity you will use the Format menu to update your formatting making your data easier to read.

Activity
Format Data with the Format Menu

1. Select the Column B.
2. Select Format > Cells to open the Format Cells dialog box.
3. On the Alignment tab, select the following (refer to Figure 7-3) and click OK:
   - Text Alignment
     - Horizontal: Center
     - Vertical: Center
   - Under Text control, check off Wrap Text.

4. Highlight the range B4:C4.
5. Select Format > Cells to open the Format Cells dialog box.
6. On the Alignment tab, set the Text Orientation to 45° (refer to Figure 7-3) and click OK.
You want to change the way the dates and costs are displayed. To do this you will use the **Number** tab in the **Format Cells** dialog box.

7. Select Column C.
8. Select **Format > Cells** to open the Format Cells dialog box.
9. On the Number tab, select the following:
   - **Category:** Date
   - **Type:** *Wednesday, March 14, 2001*

![Format Cells dialog box](image)

Date formats display date and time serial numbers as date values. Except for items that have an asterisk (*), applied formats do not switch date orders with the operating system.

10. Click **OK**.

### January’s Office Supply Expenditures

<table>
<thead>
<tr>
<th>Item</th>
<th>Date Purchased</th>
<th>Cost per Unit</th>
<th>Number of Units</th>
<th>Total</th>
<th>Percent of Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Staples</td>
<td>1/19/2001</td>
<td>1.09</td>
<td>2</td>
<td>2.18</td>
<td>1%</td>
</tr>
<tr>
<td>Folders</td>
<td>9/14/2001</td>
<td>9</td>
<td>2</td>
<td>18</td>
<td>4%</td>
</tr>
<tr>
<td>Paper</td>
<td>3/14/2001</td>
<td>22.9</td>
<td>2</td>
<td>45.8</td>
<td>11%</td>
</tr>
<tr>
<td>Toner</td>
<td>14-Mar</td>
<td>152</td>
<td>1</td>
<td>152</td>
<td>35%</td>
</tr>
<tr>
<td>Tape</td>
<td>14-Mar-01</td>
<td>1.99</td>
<td>5</td>
<td>9.95</td>
<td>2%</td>
</tr>
<tr>
<td>Dispenser</td>
<td>9.95</td>
<td>1</td>
<td>9.95</td>
<td>2%</td>
<td></td>
</tr>
<tr>
<td>Pens</td>
<td>11.49</td>
<td>10</td>
<td>114.9</td>
<td>27%</td>
<td></td>
</tr>
<tr>
<td>Pencils</td>
<td>1.22</td>
<td>6</td>
<td>9.72</td>
<td>2%</td>
<td></td>
</tr>
<tr>
<td>Lables</td>
<td>9.99</td>
<td>1</td>
<td>9.99</td>
<td>2%</td>
<td></td>
</tr>
</tbody>
</table>

![January’s Office Supply Expenditures](image)
You’ll need to resize Column C for the dates to display fully.

11. Select Column C.
12. Select Format > Column > AutoFit Selection.

Now you want to format the Cost per Unit and Total columns to make the fact that they are dollar amounts more obvious.

13. Select the ranges D5:D16 and F5:F16. (You’ll need to hold down the Ctrl key to select both ranges.
14. Select Format > Cells
15. On the Number tab, select the following:
   • Category: Number
   • Decimal places: 2
16. Click OK.
17. To make the Total stand out more, select its cell, F19.
18. Use the Formatting toolbar to select Currency Style, Bold font style and Red font color.
Excel has seventeen predefined worksheet formats to make formatting quick and easy. AutoFormats are designed for worksheets with text labels in the left column and top rows, and totals in the bottom row or right column. To use AutoFormat:

1. Select range of data to be formatted.
2. Click **Format** on the Menu bar.
3. Choose **AutoFormat**.
4. Select a format.
5. Click **OK**.

![AutoFormat](image_url)
**Conditional Formatting**

Conditional Formatting, such as cell shading or font color, is automatically applied to cells if a specific condition is true. You can monitor formula results or other cell values by applying conditional formatting. For example, you can apply green font color to the cell if sales exceed forecast and red font color if sales fall short.

To add conditional formats:

1. Select the cells for which you want to add conditional formatting.
2. On the Format menu, click **Conditional Formatting**.

3. Specify the conditions that will trigger your formatting.
4. Click on the **Format** button to choose the formatting which will be applied to cells which meet your conditions.
5. Click **OK**.

Using the **Add** button in the **Conditional Formatting** Window allows you to specify up to three conditions.

To remove one or more conditions, click **Delete**, and then select the check box for the conditions you want to delete.

> If none of the specified conditions are true, the cells keep their existing formats.

> If more than one specified condition is true, Microsoft Excel applies only the formats of the first true condition.

**Scenario:**
The budget manager informs you that there may have been some erroneous charges on your Purchasing Card on January 12th. She wants to make sure you are charged the correct amount. To quickly see what was purchased on the date you can use **Conditional Formatting**.
Activity
Apply Conditional Formatting

1. Highlight Column C to select the purchase dates.
2. Select Format > Conditional Formatting to open the Conditional Formatting dialog box.
3. Select the following (refer to Figure 9-2):
   - Cell Value is
   - Equal to
   - 1/12

4. Click on Format.
5. Select the Patterns Tab.
6. Choose Yellow.
7. Click OK.

Your worksheet should now look like Figure 9-4. Now it’s easy to find the specific date and your data is easier to read and more attractive.
For more information on Excel, the following sources are recommended:

- Try the Help menu built into Excel.
- Use the free online training and Quick Reference guide for Excel available from Microsoft at: http://office.microsoft.com/learning
- Test your knowledge by taking a short online Excel quiz at: http://office.microsoft.com/

Once at the above Web page, from the Quick Links section in the right column, choose Take a quiz. Once on the Office Quizzes Web page, from the Excel section, click on Quiz: Excel basics.

This course book was created by Cristin Richard for Boston College ITS Training & Communications, For more information about training at Boston College please visit www.bc.edu/training Documentation related to computing at BC is available at www.bc.edu/help Questions can be directed to 617-552-HELP or help.center@bc.edu