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Microsoft Excel  
for Grading 
 

 
 
 
 
The software described is Microsoft Excel 2003 running on Windows XP. 
 

 
Prerequisites 
 
You should have a working knowledge of Microsoft Excel, including how to enter 
data, work with cells and ranges, and navigate a worksheet.  You should also be 
familiar with the Windows XP desktop and with general concepts of manipulating 
windows such as menus, scrollbars and dialog boxes. 
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The Excel Workbook 
 

• A workbook is a set of worksheets.  

• You can switch between worksheets using the tabs at the bottom of the window.  

• A workbook may contain 1 to 255 worksheets. 

 
Worksheet 
 

A worksheet is a grid made up of: 
 
• Columns-the vertical space, designated by letters running across the top of the worksheet.  

• Rows-the horizontal space, designated by numbers running down the left of the worksheet. 
• Cells–the intersection of a column and a row.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Cell 

 

• Every cell may contain text, a number, or a formula. 

• Every cell is uniquely identified by a letter + number combination based on its  
column and row. 

• The active cell has a thick, dark border and it’s name displays on the cell name bar. 

 

 
 
 

Row 
Headings 
 

Select all 
 

Menu bar 

Cell Name Formula Bar Column 
Heading 

 

Active cell 

Worksheet tab 

 

Task Pane 
Status bar 
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Using Multiple Worksheets 
 
Multiple sheets are useful if you need to calculate grades from a large number of assignments. You can 
organize grading criteria by type. For example, homework assignments could be managed on one 
worksheet and quizzes on another. You can maintain your full class roster on one worksheet and 
reference it from the others. This insures that your data is consistent without having to type student 
names over and over. 
 
Inserting New Worksheets  
 

1. Go to Insert>Worksheet on the Menu bar.  
2. A new worksheet will be inserted before (to the left) of the current active worksheet. 

 
Moving Worksheets 
 

Click and drag the worksheet’s tab at the bottom of the page to the desired location. Your cursor will 
have an icon that looks like a page and a small black triangle will indicate possible new locations. 

 
Renaming Sheets 
 

1. Double click on the worksheet’s tab. 
2. The worksheet name will become highlighted and your cursor will change to allow you to insert 

text. 
3. To accept the change you made, press [Enter] or click off the tab. 

 
 

Navigating Excel 
 

• Use your scroll bars and mouse to click directly into a cell. 

• Select “Go To” from the Edit menu and type a cell address. 

• Use the tabs at the bottom of the screen to switch between worksheets. 

• Use your keyboard as described in the table below: 

 

Press Key(s):  

Arrow  Move to the next cell  (down , up , left  , r ight ) . 

Tab Move a cell  to the right . 

Enter Move to the next row.  

Page Up Move a full  screen up. 

Page Down Move a full  screen down. 

Alt + Page Up Move a full  screen to the left . 

Alt + Page Down Move a full  screen to the right . 

Home Move to the fi rst cel l  of the active row.  

Alt + Home Move to the fi rst cel l  of the active worksheet (A1) .  
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Entering and Accepting Data 
 

To enter information: 
 

1. Navigate to the cell where you want data to appear and type.   
2. Do one of the following: 

• Press the [Enter] key to accept the data and move you a row down. 

• Press the [Tab] key to accept the data and move one cell to the right 

• Click  the green checkmark on the Formula bar to accept the data while keeping your 
cursor in the same cell.  

 

Editing Data 
 

To change data before it has been accepted: 
 

1. Use [Backspace] to delete and retype the entry. 
2. Pressing [Esc] to clear the entire entry. 

 
To change data after it has been accepted: 
If you’ve already entered the data in the cell, you can still change it by using one of the following choices: 
 

1. Double-click the cell or click into the cell and press F2 to return to “edit” mode. 
2. Click into the cell and begin to type. This will overwrite the existing contents. 
3. Click into the cell and edit the data in the Formula bar. 

 

Selecting Data 
 
To select: 
 
An entire row: click on the Row Heading (the number at the left of the row). 
 
An entire column: click on the Column Heading (the letter at the top of the column).  
 
An entire worksheet: click in the box to left of Column Heading A and above Row Heading 1.   
  
 
 
 
 
 
 
 
 
A range of adjacent cells  (A range is a group of two or more cells.):  
 

“Press, drag, release” method 
Click into a cell, hold the mouse button down, and drag to make your selection and then 
release the mouse button. 
 
“First, [Shift], last” method 
Click into the cell and hold down the [Shift] key and click on the last cell to select all cells in 
between. 
 
You may select a range of entire rows or columns by using the headings and the techniques 
described above. 
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To select: 
 
Non-adjacent cells or ranges: 
 

1. Highlight the first cell or a range of cells.  

2. Press and hold the [Control] key and select additional cells or ranges.   
On a Macintosh:  use the [Command] key. 

 

 

 Excel’s Text to Speech feature allows you to audibly verify your data.  
1. From the VView menu, select: TToolbars and then select: TText to Speech. 

The Text to Speech Toolbar will display.   
2. Select the range of cells you want to verify.   
3. Click SSpeak Cel ls to have Excel read back each cell in your selection. 
4. Turn off this feature with the SStop Speaking button 

 
 
 

 
 

Moving Data 

 

“Drag-and-Drop” method 
 

1. Select the data you want to move. 
2. Move the mouse pointer over the border of the selection. The mouse pointer changes to a 

four-headed arrow. 
3. Press and hold the mouse button and drag the selection to its new location. As you move, 

an outline follows showing the shape of the selection. 
4. When it covers the area you want to fill, release the mouse button. 

 

“Cut (or Copy) and Paste” method 
 

1. Select the data to be cut (or copied). 
2. Cut. 
3. Click into the cell where you want to paste the data. If you are pasting a range of cells, click 

into the cell that you want to become the upper-left hand corner. 
4. Paste. 
 
Choices for Cut, Paste and Copy: 

 

 Edit Menu Keyboard Shortcut Toolbar Icon 

Cut Select: CCut [CCtrl] XX 
 

Paste Select: PPaste [CCtrl] VV 
 

Copy Select: CCopy [CCtrl] CC  
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Insert Copied Cells 
 
To paste data between cells that already contain data use Insert>Copied Cells from the Menu bar. 
 

1. Select and copy (or cut) the cells you want inserted between existing cells.  
2. From the Insert menu, select: Copied Cells.  
3. Select a direction to move the cells to allow the insertion.  

 

Formatting Data 
 
Excel’s default, general, format aligns text to the left and numbers to the right. You may use the 
formatting toolbar and the Format Menu to change formatting.  
 

 Formatting Tips 
• The Format menu allows you to set the number of decimal places for numbers. Select: 

Format>Cells>Number Tab>Number  
• To prevent Excel from dropping an initial 0 in zip codes or social security numbers, select: 

Format>Cells>Number Tab>Special 
 

 

Clearing Data 
 

1. Highlight the cell, range of cells, column, or row you want to clear. 

2. Select Edit > Clear from the Menu bar. 

3. Select the appropriate option: 

 
All  Clears all data and any comments and reverts the format to the general 
  default format.  

Formats Reverts the format to the general but leaves the data untouched. 

 Contents  Clears the data and any formula from the selected cells but leaves 
   formatting and any notes intact.  

Comments  Clears any notes but leaves the formatting and the data intact. 

 

Inserting Columns, Rows, Cells, and Worksheets 

 

Columns 

Inserting a Column  creates a blank column and moves all columns one column to the right, including the 
highlighted column. Select several contiguous columns to insert that same number of columns. 

1. Click on the Column Header to the right of the location where you wish to insert a new 
column. 

2. Select Insert > Columns from the Menu bar. 

Rows 

Inserting a Row  creates a blank row and moves all rows down one row, including the highlighted row. 
Select several contiguous rows to insert that same number of rows. 

1. Click on the Row Header below the location where you wish to insert a new row. 

2. Select Insert > Rows from the Menu Bar. 
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Cells 

1. Select Insert > Cells from the Menu Bar. 

2. Specify which way you want the cells to shift. 

Worksheets 

1. Select Insert > Worksheet from the Menu Bar. 

 

Deleting Columns, Rows and Cells 
 
 

1. Click on the Column or Row Header, or cell or range of cells, you wish to delete. 
2. Select Edit > Delete from the Menu Bar. 

 
• Columns shift left.  
• Rows shift up.  
• Cells you can specify which way you would like them to shift.  

 
 

Resizing Columns and Row 
 

There are three ways to adjust the width of a column or height of the row: 

1. Drag the Double-Arrow  

Position the pointer on the Column Header (or row) division line. The mouse pointer will 
change to a double-arrow indicating that you can now resize the column/row. Drag 
left/right to resize the column or up/down to resize the row. Release the mouse when the 
column is at the width you want. 

2. Select Format > Column (or Row) > Width (Height) and specify a width. 

3. Format > Column (or Row) > AutoFit Selection. 

 

 A shortcut to AutoFit a column or row is to double-click on the dividing line.  
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Overview of an Excel Formula  

A formula is a set of instructions that you enter in a cell to perform calculations on values entered into 
other cells.  

• Formulas are entered in the cell where you want the result to appear.  

• Once the formula has been entered, the result displays in the current cell.  

• The formula displays and can be edited in the Formula Bar. 

 

 

All formulas include three key elements:  

  An equal sign ( = ) to begin the formula. 

  The cell references or values you wish to include in the calculation. 

  The mathematical operator(s) to be used in the calculation. 
 
 
Values 

 

• A constant value (120) 
• A cell (B2) 
• A range of cells (B2:B10) 
• A label or a name (FirstQuarterSales) 
• A worksheet function (SUM) 
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Mathematical operators: 
 

+ Plus sign for addition. 

- Minus sign for subtraction. 

* Asterisk for multiplication. 

/ Front slash for division. 

^ Caret symbol for exponents. 

(  ) Open and close parentheses to group computation instructions. 
 
 

Order of Operations 
 

Excel calculates a formula from left to right. When more than one mathematical operator appears in a 
formula, Excel calculates according to the standard mathematical order of operations (parentheses, 
exponents, multiplication and division, addition and subtraction).  
 
 

Referencing Cells and Ranges 
 

To refer to :  Use:  

The cell in column A and row 10 A10 

The range of cells in column A and rows 10 through 20 A10:A20 

The range of cells in row 15 and columns B through E B15:E15 

All cells in row 5 5:5 

All cells in rows 5 through 10 5:10 

All cells in column H H:H 

All cells in columns H through J H:J 

The range of cells in columns A through E and rows 10 through 20 A10:E20 

 
Referencing Another Worksheet 
 

You may want to use the value from a cell in another worksheet within the same workbook in a formula. 
In the following example, the Average worksheet function calculates the average value for the range B1:B10 
on the worksheet named Marketing in the same workbook.  
 
The name of the worksheet and the cell reference is separated by an exclamation point. 
 

 

 
 
 

  Referencing Another Workbook 
 Excel allows you to reference data in other workbooks but 
 instruction on how is not covered in this lesson. 
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Function 
Arguments 

Function Name 

 

Overview of an Excel Function 

 
Functions, which are formulas “built-in” to Excel, are often a more efficient way of performing 
mathematical operations.   
 
Microsoft Excel provides over 200 built-in functions.   
 
The steps for entering a function are outlined below: 
Click the cell in which you want to display the results of the function. 
 

1. Press [ = ]. 

2. Enter the Function Name into the cell by one of the methods 
described in the table on the following page. 

3. Select or enter the Function Arguments (cell references to be used 
in the calculation enclosed in parentheses). 

4. Press [Enter]. 

 
 
 

Methods for Entering Functions 

 

 
Method Descript ion 

Manual Method 

 

Use the 
Keyboard Only 

Type the entire function directly into the cell. 

Point Method 

 

Use the 
Keyboard 
and MMouse 

Type the function name and the left parentheses, use the 
mouse to select the range(s) as the argument(s), 
separating multiple arguments with commas, and type the 
right parentheses. 

AutoSum Feature 

 

Use the 
AutoSum 
feature 

Click the AAutoSum ddrop-down arrow button located 
on the Standard toolbar to display a list of functions to 
select from. 

Insert Function 
Wizard 

 

Use the 

Insert 
Funct ion 
Wizard 

Select IInsert > Funct ion from the Menu bar or click 
the Insert Function button on the Formula bar to open 
the Insert Function dialog box (Wizard) and select from a 
list of all available functions. 
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The AutoSum Feature 

 
The functions listed and described in the table below are the most commonly used 
functions. These functions can be applied using the AutoSum icon on the toolbar: 
 

• AutoSum (addition) is the default. 
• Click on the arrow next to the icon to access the menu for other auto-functions.

  
 

Function  Example  Description  

Sum =SUM(A4:A10) Adds the values in cells A4 through A10. 

Average =AVERAGE(B1:B12) Calculates the mean average of the values in cells 
B1 through B12. 

Minimum =MIN(C5:C20) Finds the minimum value of the values in cells C5 
through C20. 

Maximum =MAX(D1:D10) Finds the maximum value of the values in cells D1 
through D10. 

Count =COUNT(A2:A18) Finds the number of numeric entries in cells A2 
through A18. 

To use the AutoSum Feature: 

1. Click into the cell where you would like the result to display. 
 

2. Click the AAutoSum button. 
 

3. Excel selects the range of data it believes you wish to work with. If Excel has chosen the correct 
range, press [Enter]. 
 

4. If Excel has chosen the incorrect range, simply click and highlight the correct range, and then press 
[Enter]. 
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Copying Formulas Using AutoFill 
 
You often will want to use the same formula or function multiple times in the same worksheet. Using 
AutoFill will save you time because you won’t have to retype the formula or function over and over. 
 

You can quickly and easily copy formulas into adjacent cells by using the AAutoFi ll  Handle   (the 
small black square in the lower-right corner of the selection.  
 
To copy a formula using AutoFill: 
 

1. Click anywhere inside the cell that you want to copy 
to select it. 

2. Rest the mouse pointer on the FFil l  Handle at the 
lower-right corner of the selected cell. 

3. The mouse pointer will change to a solid cross. 
4. Once the pointer has changed to a solid cross, click 

and hold the mouse button down and drag the FFi ll 
Handle to the adjoining cell(s) that you want to 
copy into. 

5. Release the mouse button. Excel fills the cell(s) with 
the copied formula using relative referencing. 

 
To copy a formula to a nonadjacent cell, use any of the copy/paste functions described on page 5. 

 
 

Editing and Deleting Formulas and Functions 

To change cell references in a formula: 

1. Double-click the cell that contains the formula you want to change.  
 

2. Do one of the following:  

• To move a cell or range reference to a different cell or range: drag the color-coded border 
of the cell or range to the new cell or range. 
 

• To include more or fewer cells in a reference: drag a corner of the border. 
 

• In the formula, select the reference, and type a new one. 

3. Press [Enter]. 

  When you enter or edit a formula in Microsoft Excel, cell references and the borders 
 around the corresponding cells are color-coded to guide you. 
 
 
To delete a formula: 

1. Click the cell that contains the formula. 
 

2. Press [Delete]. 
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Absolute vs. Relative Referencing 
 
Relative Referencing 
 

When a formula contains relative referencing and it is copied from one cell to another, Excel does 
not create an exact copy of the formula. It will change cell addresses relative to the row and 
column they are moved to. If you copy the formula across rows or down columns, the reference 
automatically adjusts. 
 
By default, new formulas use relative references. For example, if you insert a formula in cell B3 
which references cell A3, when you copy it to cell B4 the formula automatically adjusts from 
=A3 to =A4. 
 
When you do not want this to happen, you need to reference your cell using absolute referencing. 

 
Absolute Referencing 
 

An absolute cell reference in a formula, such as $A$1, always refer to a cell in a specific location. 
If the position of the cell that contains the formula changes, the absolute reference remains the 
same. If you copy the formula across rows or down columns, the absolute reference does not 
adjust. 
 
To create an absolute reference, place dollar signs "$" within the cell addresses in the formula. 
 
For example: 

 

$A1 As this formula is copied, it will always reference the contents of column A, but 
the row may vary if the formula is copied down to a different row. 

A$1 As this formula is copied, it will always reference the contents of row 1, but the 
column may vary if the formula is copied across the spreadsheet. 

$A$1 Regardless of where the formula is copied, it will always reference the contents 
of cell A1 in column A, row 1. 
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Using the Insert Function Wizard 
 

It is helpful to use the Insert Function wizard when you are not sure what function to use or 
when you need assistance stepping through the function. 
 
To access the wizard, choose Insert > Function from the Menu bar or click the Insert Function 

button on the Formula bar.  
 
The table and illustration below describes the Insert Function dialog box. 

 
 

 
 
  
 

 Option Descript ion 

a Search for a function Type a brief description of what you want to calculate and click Go. 
Excel will list all functions matching your search criteria in the Select 
a function list box. 

b Select a category To narrow your search, click the Select a category drop-down arrow, 
select a function category and click Go. 

c Select a function Scroll through the Select a function list box, click to highlight the 
function you want and click OK. 

d Description When you highlight a function, a description of what it does displays 
making it easier for you to make a selection. 

e Help on this 
function 

Highlight a function in the Select a function list box, then click the 
Help on this function hyperlink to open the Microsoft Office Help 
window with detailed information about the function selected. 

e 

d 
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Function Arguments 
 

After you choose a function, the Function Arguments dialog box will open, providing you with a 
text box(es) into which you insert the necessary cell range(s).  

 
The Collapse Button 
 

If you are not sure what cell reference to use, click on the Collapse button to return to the 
spreadsheet where you can directly select cell ranges with the mouse rather than typing. Once 
you have made your selection click the Restore button  to reopen and return to the dialog box.  
 
You may also switch to another worksheet to make your selection. 

 
 

 
 
Insert Function Wizard Steps 
 

1. Select the ccel l  you want to contain the function. 

2. Click the IInsert Funct ion button  on the Formula bar.  

3. Search for an appropriate function or click the sselect a category drop-down arrow and: 

• Select AAll  to display a listing of all available Excel functions or 

• Select a more specific category based on the function you wish to use 

4. From the SSelect a funct ion list box, select the desired function. 

5. Click OOK. 

6. The FFunct ion Arguments dialog box appears. 

7. In the NNumber text box, type the value and/or cell references to be used in the function or 
use the Collapse button to select the range with your mouse. 

8. Click OOK. 

9. The FFunct ion Arguments dialog box closes. Excel calculates and enters the result in the 
cell. 
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AVERAGE (Mean) 
 

Finds the average (mean) value of all the values in a specified range of cells. 
 
=AVERAGE(range) 
 

• Average can be calculated using the AutoSum Feature (see page 12). 
 

  When calculating an average, Excel will ignore any cell that is blank.  
 Make sure to enter a zero if the cell should be included in the calculation. 
 
 

MAX 
 
Finds the maximum (largest) value of all the values in a specified range of cells. 
 
=MAX(range) 
 

• Max can be calculated using the AutoSum Feature (see page 12). 
 
 

MIN 
 
Finds the minimum (smallest) value of all the values in a specified range of cells. 
 
=MIN(range) 
 
 

• Min can be calculated using the AutoSum Feature (see page 12). 
 

 

MEDIAN 
 

Finds the value for which half of all the values are greater and half are lesser in value in a specified 
range of cells. 

 
=MEDIAN(range) 
 
 

MODE 
 

Finds the most common value within a specified range of cells. 
 

=MODE(range) 
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CONCATENATE 

The CONCATENATE function creates a text string by pulling data from specified fields.  

=CONCATENATE(text1,text2,...) 
 

• Text1, text2, ...    are 1 to 30 items to be joined into a single text item.  

• Text items can be text, numbers, or single-cell references. 

• To add supplementary text between fields, type the text in quotation marks.  

• To add a space between fields, type " ". 

Grading example:  
 
Concatenate is useful for joining first and last names into one cell. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

ISBLANK 
 
The ISBLANK function tests whether a certain cell is blank (empty). If the cell is blank the result will be 
“true”. If the cell is not blank the result will be “false”.  

 
=ISBLANK(cell) 
 
• ISBLANK evaluates a single cell not a range of data. 
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IF 
 
The IIF Function checks a condition that must be either true or false. If the condition is true, the function 
returns one value. If the condition is false, the function returns another value.  
 
The function has three arguments: 
 

 ( 1 ) The condition you want to check. 

 ( 2 ) The value to return if the condition is true. 

 ( 3 ) The value to return if the condition is false. 

IF(llogical_test,vvalue_if_true,value_if_false) 

Logical_test is any value or expression that can be evaluated to TRUE or FALSE.  

For example, A10=100 is a logical expression; if the value in cell A10 is equal to 100, the 
expression evaluates to TRUE. Otherwise, the expression evaluates to FALSE. 

Value_if_true is the value that is returned if logical_test is TRUE.  

• Value_if_true can be another formula. 

Value_if_false is the value that is returned if logical_test is FALSE.  

• Value_if_false can be another formula. 

Grading examples: 

Formula  Description (Result) 
 

=IF(A2<=1.67,"Needs Help","OK") 

 

where A2 is the GPA 

If the number (GPA) is less than or equal to 1.67, 
then the text "Needs Help” displays, otherwise, 
the text "OK” displays. 
 

 
=IF(F2>D2, (F2+D2/2), D2) 

 

where D2 is score of Exam 1 and 

F2 is the score of Exam 2 

 
If the number in F2 (Exam 2) is greater than the 
number in D2 (Exam 1), add the two exams 
together and divide by 2 (the average of the two 
exams). If the score of Exam 2 is not greater than 
the score of Exam 1, use the score from Exam 1) 
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COUNT and COUNTA 
 
Counts the number of entries in a range of cells.  
 

=COUNT(range) 
 
• COUNT is included as an AutoSum Feature (see page 12). 

• COUNT WILL NOT count blank cells or cells that contain text. 

 
 

=COUNTA(range) 
 
• Use COUNTA to evaluate cells that contain text. 

 
Grading example:  

 
COUNT is useful if you have a large class and want to determine how many students have turned 
in a particular assignment.  

 
 

 

COUNTBLANK 
 

Counts the number of blank cells in a particular range.  
 

=COUNTBLANK(range) 
 
Grading example:  

 
COUNTBLANK is useful if you have a large class and want to determine how many students have 
NOT turned in a particular assignment.  

 

COUNTIF 
 

Counts the number of cells that are the same as a particular search string.  
 
=COUNTIF(range, “string”) 
 
Grading example: 
 
Using COUNTIF, you can set up a grid to view the distribution of letter grades. This is useful if you 
are grading against a curve.  
 
=COUNTIF(range, “A-”) 

=COUNTIF(range, “A”) 

=COUNTIF(range, “B+”) 
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STDev - Standard Deviation 
 

Standard deviation measures the spread of data about the mean, measured in the same units as the data. 
 

=STDev(arguments) 
 
Grading example: 
 
Calculating the standard deviation is useful when analyzing student scores and assigning grades 
against a curve. 
 

  Compare individual scores to the standard deviation using the following formula: 
Student’s Score – average of all scores / standard deviation 
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Calculating a Weighted Mean (Average) 

 
A weighted mean is the average of a collection of scores/values that have been assigned different degrees 
of importance.  

Example (based on a 100 point scale) :   

Your course may have two papers and a final exam; you may want each paper to count for 15% of the final 
grade and the exam to carry more weight, 70% of the final grade. 

 If the student scores 86, 94, and 80 respectively, his/her final grade would be an 83. 

 A B C D E 

1 Student Paper Paper Final Exam Weighted Mean 

2 Smith 86 94 80 83 
 
To figure the weighted average, multiply each score by the percent of the final grade and then add each 
result  together. 

 
 (86 * .15) + (94 *.15) + (80 *.7)   =   83 
 

If you are not comfortable converting to decimals, you can use the following formula: 
 
(score * percent) + (score * percent) + (score * percent)   =   

100 
 

(86 * 15) + (94 * 15) + (80 * 70)   =   83 

100 

Using the table above, the formula would be written as: 
 

=(B2 * .15) + (C2 * .15) + (D2*.7) 
  
 
Sometimes it is useful to enter each “weight” as a row in the table: 
 

 A B C D E 

1 Student Paper Paper Final Exam Weighted Mean 

2 Weight .15 .15 .7  

3 Smith 86 94 80 83 

 
The formula would than be written as: 
 

=(B3 * B2) + (C3 * C2) + (D3 * D2) 
 

 If your grading is sometimes based on 100 but not always, you 
 will first need to convert the data to the 100-point scale (100%).  
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Converting to Percentage 
 
If you have assignments with different total possible points, it is often helpful to standardize them all to a 
percent scale. To do this, you need to divide each student's score by the total possible points for that 
assignment and then multiply by 100. 
 
Example:   
 

Student A receives a 12 on a quiz with a total possible score of 14.  
 
=12/14*100 
 
= 86 (rounded to the nearest whole number) 

 
  
 
To calculate a weighted mean with items that have different point scales, use the formula described above 
combined with the formula for calculating a weighted average. 
 
 
 
 
 
 
 
 
 
 
 
 

=12/14*100*.15+19/25*100*.15+85*.3+83*.4 
 

= 83 (rounded to the nearest whole number) 
 

 The result of 83 is returned in Excel when numbers are formatted for  
 0 decimal places using Format>Cells>Number Tab. 
 

 
The formula would be written as: 
 

=(B3/B1*100*B2)+(C3/C1*100*C2)+(D3/D1*100*D2)+(E3/E1*100*E2) 
 
Since two of the items are already based on a 100-point scale, the formula could be shortened to: 

 
=(B4/B2*100* B3) + (C4/C2*100)*C3) + (D4 * D3) + (E4 * E3) 
 
If you haven’t entered the scale and weight as a row in your worksheet, you would write the 
formulas as follows: 
 
=(B4/14*100* .15) + (C4/25*100)*.15) + (D4 * .3) + (E4 * .4) 
 
 

 A B C D E F 

1 Student Quiz 1  Quiz 2 Paper Exam 
Weighted 

Mean 

2 Scale 14 25 100 100  

3 Weight .15 .15 .30 .40  

4 Smith 12 19 85 83 83 
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Dropping Low Scores 
 
Dropping the Lowest Score 
 
Dropping the lowest homework or quiz score before calculating an average is a common grading practice.  

 
 
 
 
 

 
 
If you would like to find an average for homework assignments after dropping the lowest score, you would 
use the following: 
 

=(SUM(B2:E2)-MIN(B2:E2))/3  
   
 

  CAUTION:  
 
Be careful to consider OOrder of Operat ions. 
 
 =SUM(B2:E2)-MIN(B2:E2)/3   
 
 will result in a very different answer than: 
 
 =(SUM(B2:E2)-MIN(B2:E2))/3    
  

  
 

The Function SMALL 
 
Excel’s SMALL function is useful if you would like to determine the second or third lowest score. The 
syntax of the SMALL function is: 
 

=SMALL(range,n) where n represents the nth smallest number in the data set. 
 
In the example above the SMALL function =SMALL(B2:E2, 2) would result in the score: 85 (the second 
lowest grade). 
 
Dropping the 2 Lowest Scores 
 
Using the sample above, if you would like to drop the two lowest grades before calculating an average the 
formula would be: 
 

=(SUM(B2:E2)-MIN(B2:E2)-SMALL(B2:E2,2))/2  
 

 A B C D E 

1 Student HW 1  HW2 HW3  HW4  

2 Smith 95 87 85 83 
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Using VLOOKUP to Assign Letter Grades 
 
You can use VLOOKUP to search a range for a particular score and then substitute that score for a letter 
grade. 

To use the VLOOKUP function to assign letter grades, you must first create a reference (lookup) table. 
VLOOKUP enables you to search a list for a value in one column and then return a corresponding value 
from a second column. Therefore our lookup table must be a minimum of two columns. 

Create a Reference Table 
 

1. Switch to a blank worksheet.   

2. In the first column, enter the cut-off values for the letter grades 
and in the second column the corresponding letter grade. 
 
  

  CAUTION: The reference table must display in  

 ascending order ( lowest score to highest).  

 

3. It is a good idea to name the range of data for easy reference in 
the function. To name the range: 

a. Select the data in BOTH columns.  
In our example the range to select is: A1:B12. 

b. Select Insert>Names>Define from the Menu bar and type: grades in the  
Names in workbook: box 

c. Click Add.  

d. Click OK.  

 

  



   30 

VLOOKUP 
 

The basic syntax of the VLOOKUP function is:  
 
=VLOOKUP(lookup value, lookup table range, value column).  

 

 

 

 

 

 

 
• It is a good idea to use the Insert Function Wizard to guide you. 

 
• The table above and the reference table created and named “grades” is used as an example to 

illustrate the process. 
 
The wizard asks you complete the following fields: 
 
FIELD DESCRIPTION 
 
Lookup_value Enter the cell name for the numerical score that you want to change to a letter 

grade. Enter the cell address or use the Collapse button to select it with your 
mouse. 

 
 In our example, F2 is entered. 
 
Table-array The range that holds the lookup data. Enter the range address. If you have named 

the range, enter the name or use the Collapse button to select the range with your 
mouse. 

 
 In our example, the named range: grades is entered. 
 
 
Col_index_num The number of the column that holds the letter grade (To indicate the second 

column in the range type: 2) 
  
 In our example, 2 is entered. 
 
Range_lookup Enter: True or leave the field blank. 
 

Enter: False if you want to find an exact match instead of a match that falls between 
a range of values. 
 
In our example, the field is left blank. 
 

In the example the VLOOKUP function would be entered into cell G2 and would read: 
 

=VLOOKUP(F2,grades,2) 
 
Use AutoFill to copy the function to other cells using relative referencing. 
 

 A B C D E F G 

1 Student Quiz 1  Quiz 2 Paper Exam 
Weighted 

Mean 
Letter Grade 

2 Smith 12 19 85 83 83  
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Using COUNTIF to Determine Distribution of Grades 
 

Once you have determined letter grades using VLOOKUP, use COUNTIF to determine the distribution of 
grades. 
 

1. Select the range of letter grades for each student. In this 
example the range would be L2:L15. 

2. Name the range “lettergrades” (Insert>Name>Define). 

3. Switch to the worksheet that displays your grade reference 
(lookup) table: 

 
 

4. In column C, use COUNTIF to count the distribution   
of each grade. Enter the function once and then use 
AutoFill to copy it to the other grades.  
 
=COUNTIF(lettergrades,B2)  
 

5. Use AutoFill to copy the function for each grade. 
 
  
 
 

 
 

 
 

 
 

 Use Excel’s Chart Wizard to quickly  
chart the grade distribution.  
 

1. Highlight the range of grades and counts. 
(B1:C12) 

2. From the Insert menu, select Chart.  

3. Step through the Chart Wizard.
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Creating a Histogram  
 
Using Excel’s Add-On Analysis ToolPak, you can easily create a histogram for a range of numerical 
scores. 
 
Loading the Analysis ToolPak 
 

Open the Tools menu. If you do not see Data Analysis listed (near the 
bottom), select Add-Ins. In the Add-Ins dialog box, click the checkbox next to 
Analysis ToolPak and then click OK. 

 
 
Input Range 
The illustration at right depicts the range of exam scores. This is the data that  
will be evaluated. This is the Input Range. 
 
 
 
Create a Bin Range 
First you need to create a Bin Range. The Bin range represents the values for which we 
want frequency counts. Determine the highest and lowest values in the Input Range data. 
You can use the MIN and MAX functions. 
 
Once you have determined the highest and lowest values, use AutoFill to automatically 
create the Bin values: 
 

1. Type the minimum (smallest) value. In our sample type: 7. 

2. Select Edit> Fill >Series from the Menu bar.  

3. Select series in: Columns. 

4. In the Step value field, enter the 
increment you would like to use (1, 

2, etc.). For the example, enter: 1. 

5. In the Stop value: field type the 
highest value in your Input Range or a 
number close to that value. For the 
example, enter: 15. 

6. Click OK. 

 

The series will AutoFill: 
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Creating the Histogram 

 
1. Select: Tools > Data Analysis from the Menu bar. 

 
2. Select:  Histogram from the list and click OK. The Histogram dialog box will open. 

 
3. Use the Collapse button to select the 

Input range with your mouse. 
 

4. Use the Restore button to return. 
 

5. Use the Collapse button to select the 
Bin range. 

 
6. Use the Restore button to return. 

 
7. Under Output Options, select where 

you want the frequency table and chart 
to be placed. You can use the Collapse 
button to select a cell in your current 
worksheet (under your Input and Bin 
data) or you can select to have the 
Output placed on a new worksheet. 

 
8. Make sure to select Chart Output.  

 
9. Click OK. 

 
The frequency table and chart (histogram) will display where you specified. 
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Freeze Panes 
 

When you are dealing with a large class it is helpful to keep the titles of the columns and the names of 
the students visible at all times. You can accomplish this by using Freeze Panes. 
 

1. Click into the cell that is after the column and below the row, which you would like to freeze.  

2. Click Window>Freeze Panes. 

3. No matter where you scroll on the worksheet, the contents of these cells will remain visible. 

 

Printing Tips 
 
Set Print Area 
 
To print out a portion of a worksheet (e.g., certain columns) you can set a print area. 
 

1. Highlight the range of data  you want to print. 

2. Select File>Print Area from the Menu bar. 

3. Select:  Set Print Area.  

4. Use print preview to verify what will print. 

To remove the print area 
 

1. Select: File>Print Area from the Menu bar. 

2. Select: Clear Print Area. 

 
Printing Header Rows and Columns 
 
If your class has more students than fit on a single printed page, you will want to print out the column 
headers on each page.  
 
Also, if you have more assignments than fit on one printed page, you may want to print student-identifying 
information on each page. 
 

1. Select File>Page Setup from the Menu bar. 

2. Choose the tab labeled: Sheet.  

3. Click into the field labeled: Rows to repeat at the top. 

4. Use the Collapse button  to return to the worksheet to select the Row(s) you would like to 
repeat. 

5. Click the Restore button  to return to Page Setup. 

6. Click  into the field labeled Columns to repeat at left: 

7. Use the Collapse button  to return to the worksheet to select the column(s) you would like to 
repeat. 

8. Click the Restore button  to return to Page Setup. 
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Obtaining a Class List through Agora 
 

 
Class lists in Excel can be obtained from Agora. 
 

1. Open your Web browser and go to: https://agora.bc.edu  
 

2. Log in with your BC username and password.  
 

3. From under “My Services”, select Course Rosters/Photos. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. From the dropdown menu next to your desired course, select Get a Course Roster.... 
 
 
 
 
 
 
 
 
 
 
 

5. Select your preferred 
format.  

 
6. Check the choice for: 

Other options: Also 
send as excel 
enclosure to my e-mail 
account.  
 

7. Click: Get Course 
Roster .   

 
 
 
Your class list in an Excel worksheet will be emailed to you as an attachment. The name of the file will be 
the same as the class code. Look for a message from: Web Server. 
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Act iv it ies 
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Activity 1  

 Use Excel Basics to Cleanup the Class Roster and Add Final 
Grade Criteria 

 
1. Open the file named: Excel Grading.xls. 

 
2. Click on the worksheet tab named: Roster. 

 
This worksheet contains sample data and approximates a class roster downloaded from Agora.  
 

 NOTE: Instructions for obtaining a class roster through Agora can be found on  
 page: 33 of the Excel for Grading coursebook. 
 

3. Select column A by clicking the heading. 
 

4. Select EEdit> Delete from the Menu Bar. 
 
The Student Eagle ID data is now in Column A. 
 

5. Select columns D through M using the “FFirst ,  Shi ft ,  Last” method. 
a. Click on the Column D header.  
b. Press and hold the [Shift] key down.  
c. Click on the Column M header.  
d. Release the mouse button 

 
Columns D through M should now be selected. 

 
6. Select EEdit>Delete from the Menu Bar. 

 
7. Add the column labels using the this table as a guide: 

 
 
 
 
 
 
 
 
 

8. Click on the Heading for Row 1. 

9. Apply formatting by clicking on the Bold icon on the toolbar.   
 

Cell Type: 

D1 Quiz 1 

E1 Quiz 2 

F1 Quiz 3 
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Activity 2  

 Enter a Formula and Explore Order of Operations 

 
1. Click on the worksheet tab named: Practice in the file named: Excel Grading.xls. 

 
2. If you have already used the worksheet to practice, clear all data.  

 
Select the entire sheet by clicking in the box to left of Column Heading A and above  
Row Heading 1. 
 

 
 

3. Select Edit>Clear>All from the Menu bar. 
 

4. Navigate to Cell B2. 
 

5. Type: =3+4*5  
 

6. Hit [Enter] 
 

7. Note the result that displays in Cell B2. 
 

8. Use the Formula bar to edit the formula. Add parentheses around 3+4. 
 
=(3+4)*5 
 

9. Note the result that now displays in Cell B2. 
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Activity 3  

 Use the AutoSum and AutoFill features on  
Homework Assignment Data 

 
1. Click on the worksheet tab named: Homework in the file named: Excel Grading.xls. 

2. Click into Cell G2. 

3. Click on the pull down menu next to the AutoSum icon and select 
Average. 

4. Excel selects the correct range (B2:F2) 
 

 

5. Click the green checkmark on the formula bar. 

6. Tab to Cell H2. 

7. Click on the pull down menu next to the AutoSum icon and select Max. 

8. Excel selects the range B2:G2. Since we do not want to include the Average (Cell G2) in the 
formula, we need to reselect the range. 
 
Click on cell B2 with the mouse button still depressed, drag to cell F2.  

9. Release the mouse button and press [Enter]. 

10. Click into cell I2. 

11. Click on the pull down menu next to the AutoSum icon and select Min. 

12. Excel selects the range B2:H2. This is not correct. 

13. Click the green checkmark. 

14. Edit the function in the formula bar so that the range is corrected: 
 
Change the “H” to an “F”.  
 
=MIN(B2:F2) 

15. Click the Green 
checkmark. 

16. Select the range: G2:I2  
  

17. Position your mouse on 
the lower right corner of 
cell I2. When the mouse turns into a solid black + sign, click and drag down to Row 15 and then 
release the mouse button. 
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Activity 4  

 Dropping the Lowest Grade 

 
In this exercise, we will step through the formula to drop the lowest grade on our practice spreadsheet of 
homework assignments. We will then recalculate the average. 

 

We have already found the lowest grade using the MIN function. We now need to find the Sum for all the 
homework assignments, subtract the lowest and then find a new average based on the new number of 
assignments (4). 

 
Test your new skills.  

Write down what you think the formula will be if we want the result to display in cell J2 with relative 
referencing. 
 
 

_______________________________________________________________________ 

 

 

 

 

Explanation of the Formula: 

First we type an equal sign to indicate to Excel we want to perform a calculation. 

 = 

We want the sum of the range B2:F2 
  

=SUM(B2:F2) 

We then want to subtract the Lowest grade which we found using the MIN formula in cell: I2 

=SUM(B2:F2)-I2 

The next step is to divide by the new number of assignments to find the new average (4). 

=SUM(B2:F2)-I2/4 

We need to account for the standard mathematical order of operations to prevent the division from 
occurring first. We accomplish this by placing parentheses. Our formula should read:  

=(SUM(B2:F2)-I2)/4 

 

1. Click on the worksheet tab named: Homework in the file named: Excel Grading.xls. 

2. Click into Cell J2. 

3. Enter the formula: =(SUM(B2:F2)-I2)/4 

4. Click the green checkmark on the formula bar. 

5. Use the AutoFill feature to complete the formula for the other students. 
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Activity 5  

 Use Insert Function to Find the Mode for Homework Assignments 

 
The MODE function finds the most common value within the argument. 
 

1. Click on the worksheet tab named: Homework in the file named: Excel Grading.xls. 

2. Select the ccel l  you want to contain the function; Click into Cell B19. 

3. Click the Insert Function button  on the Formula bar.  

4. Locate the Mode function.  
 
Tip: you can enter “Mode” in the Search field to retrieve it quickly. 

5. From the Select a function list box, select Mode. 

6. Click OK. 

7. The Function Arguments dialog box appears. In the Number text box, you will notice 
that Excel has anticipated what data you want to use and has filled in a range reference. 

8. To verify that this is the correct range and to gain practice using the Collapse button, 
Click the Collapse button and select the range for Assignment 1 with your mouse.  

9. Click the Restore button to return to the Function Argument Window. 

10. Click OK. 

11. The mode of “93” displays in cell B19. 

12. Use the AutoFill feature to fill right, displaying the Mode for the other homework 
assignments. 
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Activity 6 WORKSHEET 

 Calculating a Weighted Average 

The following table is an example of a grading plan based on the data in our practice Excel Workbook. 

Cell Reference 
Final Grade Sheet 

First Row of Data 

Item Total Possible Points Percent of Final 
Grade 

E2 Homework 100 10 

F2 Quiz 1 13 10 

G2 Quiz 2 15 10 

H2 Quiz 3 15 10 

I2 Paper 100 20 

J2 Exam 100 40 

 100 

The formula below changes all the data to a 100 point scale and assigns the percent of the final grade as 
displayed in the table. 

=(E2*.10)+(F2/13*100)*.10+(G2/15*100)*.10+(H2/15*100)*.10+ 

(I2*.20)+J2*.40 
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For additional information on Excel, the following sources are recommended: 
 

• Try the Help menu built into Microsoft Excel. 
 
• Use the free online training and Quick Reference guide for Excel available from Microsoft: 

http://office.microsoft.com/excel 
 

• Learn about Microsoft e-Learning at Boston College  
http://www.bc.edu/training 
 
Microsoft's e-Learning allows Boston College faculty, staff, and students to take advantage 
of a wide range of online courses that cover Microsoft's operating systems (XP and Vista) 
and Office applications (Word, Excel, PowerPoint, etc.) whenever they want. You must be 
using Windows and Internet Explorer; the Microsoft e-Learning classes are not accessible 
on a Mac or with any other Web browser. 
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