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Course Objectives and Prerequisites 
 
Introduction to Microsoft Excel is comprised of two separate classes, Part 1 and 
Part 2. 
 
 
The aim of Introduction to Microsoft Excel: Part 1 is to show you how to: 

• Navigate the Excel Workbook. 
• Create a basic worksheet by entering text and values. 
• Work with cells and cell data by using a variety of moving and copying 

techniques. 
• Perform calculations on data using the AutoSum feature. 

 
The aim of Introduction to Microsoft Excel: Part 2 is to show you how to: 

• Enhance a worksheet with formatting. 
• Sort data in Excel. 
• Set page display and printing options. 

 
 
The software described is Microsoft Excel 2010 running on Windows 7. 
 
 
Prerequisites-Part 1 
You should be familiar with the Windows 7 desktop and with general concepts of 
manipulating windows such as menus, scrollbars and dialogue boxes.  
 
Prerequisites-Part 2 
Students should have taken the Introduction to Microsoft Excel Part 1 class or have 
equivalent experience. Students must be comfortable navigating in Excel and entering 
data. 
 
 
 
 
 
 

 
 

 
 
 
 

 

Key: 
 

Caution —  

Cool Tip —  

Please Note —  
Hands-On Activity —  
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Lesson 1 
Starting Out with Excel 
 
In this lesson we'll… 

 Talk about what you can do with Excel. 
 Open up a new Excel worksheet and 

identify the different elements. 
 Learn to enter and edit data. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
  

Go from piles of paper 
to productivity! 
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1-A: What Can You Do with Excel? 
 
Microsoft Excel is an electronic spreadsheet program.  An electronic 
spreadsheet produces professional-looking documents that perform numeric 
calculations rapidly and accurately.  

• Excel makes it easier to experiment with numbers and create “what-if” 
scenarios. 

• With an Excel spreadsheet you can type in equations once and then 
change the data many times with the computer automatically re-doing 
the calculations for you (unlike using a hand-held calculator or working 
out equations by hand!). 

 

 

 

Figure 1-1: Paper Ledger    Figure 1-2: Excel Worksheet 

• Once we have the formulas set up, we can change the variables that are 
called from the formula and watch the changes.  

 
Figure 1-3: A change in data 

Figure 1-3 illustrates how a worksheet is instantly updated if one of the entries is 
changed. 
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1–B: The Excel Workbook 
 
When you open Excel, a new workbook is created for you. A workbook is a set of 
worksheets. A worksheet (or spreadsheet) is a "page" in your workbook. Excel 
allows you to quickly switch between different worksheets in a workbook using 
tabs at the bottom of the screen. 
 
To create a new Excel workbook:  

1. On the taskbar, click the Start button.   
2. In the Start menu, point to Programs (or All Programs). 
3. In the Programs menu, click the Microsoft Excel program icon.   

 
When you create a new workbook in Excel, you begin with three worksheets. 
You can add many more worksheets to a workbook if you need them (up to 
255).  
 
A worksheet is a grid made up of: 

• columns 
• rows 
• cells (the intersection of a column and a row) 

 
 
Columns  
In a worksheet the column is defined as the vertical space that is going up and 
down the window. Columns are designated by letters running across the top of 
the worksheet.  
 

 
Figure 1-4: Column C is selected 
 
  

 The Excel 
worksheet is a grid 
of 16,384 columns 
by 1,048, 576 rows 
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Rows 
In a worksheet the row is defined as the horizontal space that is going across the 
window. Numbers are used to designate each row’s location.  
 

  
Figure 1-5: Row 4 is selected 
 

Cells 
A cell is the intersection of a row and a column. Cells are referenced by the column 
letter followed by the row number.   
 

 
Figure 1-6: Cells are the intersection of columns and rows 
 
The cell highlighted in the picture is called cell A1, since the cell is the 
intersection of Column A and Row 1.  The cell to the right of it is B1, the cell 
below it is A2, etc. 
 
In each cell there may be the following types of data:  

• text (labels) 
• number data (constants) 
• formulas (mathematical equations that do all the work) 

  

Active Cell 

Row 

C
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The Mode Indicator 

The mode indicator appears on the left side of the status bar and specifies the 
condition of the active cell. If Excel isn’t working the way you expect it should, check 
the mode indicator.  You may need to press the [Enter] key to return to the Ready 
mode. 
 
The Formula Bar  
 
If you have entered text or number data the contents of the active cell will ALSO 
display in the formula bar.  
 
If you have entered a formula, as in Figure 1-7, the result of the formula will display in 
the active cell and the formula will display in the formula bar. 
 

 
Figure 1-7: The Formula Bar 
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1–C: Navigating in a Worksheet  
 
With over a million cells available to you, it is important to know how to move around, 
or navigate, a worksheet. Understanding how to get around in Excel is one of the most 
important skills you can master. It helps you work faster and more accurately.   
 
Excel places new data into your worksheet’s active cell. The active cell is indicated by a 
thick, dark border surrounding it. 
 

  
Figure 1-8: The Active Cell is B2 
 

Press: Move: 

[tab] key one cell to the right 

[Enter] key (return on some keyboards) to the line below 

an arrow key (↓ ↑ ← or →) one cell in the direction of the arrow 

[Page Down] one screen down 

[Page Up] one screen up 

[Alt] [Page Down] one screen to the right 

[Alt] [Page Up] one screen to the left 

[Home]. to the first cell (column A) of the active 
row. 

[Ctrl] [Home]. to the first cell in the worksheet (A1) 

___________________________________________ 

You can also use the mouse pointer to click directly on the desired cell. 

If the desired cell is not visible in the worksheet window, use the scroll bars or the Go 
To command on the formula bar where you can enter a cell reference to move directly 

to that cell. 
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Entering Information 
 
To enter information into a worksheet: 

1. Navigate to the cell where you want the data to appear and type.  
 

2. Navigate to another cell to enter the data.  
 
If you would like to enter the data without moving to a different cell, click the 
checkmark on the formula bar [  ]. This option is used more frequently when 
entering formulas. 

 

 Activity 1 - 1 
Enter Data into a Worksheet 

 
 
Scenario: You have been handed a piece of paper with training room expenses 
handwritten. You need to create a worksheet to hold this information and 
information that will be added later in the year.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-9: Handwritten Paper Ledger 
 
 

1. Click the mouse button to select cell A2. 

2. The active cell is now A2. Type “Months” in cell A2 and press [ Tab ]. 

• Pressing [ Tab ] after typing data will enter the data in that cell and move 
you to the cell to the right. 

3. The active cell is now B2. Type “BJ’s” in cell B2 and press [ → ] to move right 
to cell C2. 

• Pressing [ → ] after typing data will enter the data in that cell and move 
you to the cell to the right. 

4. The active cell is now C2. Type “Kinkos” in cell C2 and click the mouse button 
on the green check mark in the Formula Bar (Refer to Figure 1-10). 

• Clicking [  ] on the Formula Bar will enter the data in that cell and keep 
you in that cell. 
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Figure 1-10: Enter Data with Check Mark  

5. Click the mouse button to select cell D2. 

6. The active cell is now D2. Type “Totals” in cell D2 and press [ Enter ]. 

• Pressing [Enter] after typing data will enter the data in that cell and 

move you to the cell/row below. 

7. Finish entering the data from the handwritten ledger in Figure 1-9.  

8. When you are finished, your Excel worksheet should look like Figure 1-11 below. 

 
Figure 1-11: Excel Worksheet through March 
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1–D: Getting Help 
 
When you work with Excel, there will be times when you’ll need some 
additional assistance with a particular task.  There are great help resources built 
into all of the Microsoft Office products.  To get help, choose one of the 
following methods: 
 

 Office Assistant—Press F1. 

 Click the Help menu in the upper right hand corner.  

 

  
 Microsoft eLearning at Boston College available for Windows users. 

 
 VIEW: www.bc.edu/mselearning 
 
 Develop your skills, anytime and anywhere, with self-paced online 

tutorials from Microsoft.  
 

 

1–E: Editing Data  
 
After entering the text and numeric data in your worksheet, you may find that 
you need to make some changes to that data.  In this lesson, we'll talk about 
how to edit existing data. 
 
To change data before it’s entered in a cell: 
When you’re entering data in a cell, what happens if you type some 
information into a cell incorrectly?  If you haven’t pressed [Enter], you can 
change the entry.  This feature can save you time when editing your worksheets.  
To change an entry before you enter it into a cell, you can complete either of the 
following two choices: 
 

1. To delete characters, press [Backspace]. 
 

2. Press [Esc] to clear the entire entry. 
 
 
To change data after it's entered in a cell: 
If you’ve already entered the data in the cell, you can still change it by 
completing either of the following three choices: 
 

1. Double-click the cell to return to Edit mode. 
 

2. Click on the cell and press F2. 
 

3. Click on the cell and type new information. The contents of the 
cell will be overwritten.  
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 Activity 1 – 2 
Edit Data in a Worksheet 

 
Scenario: 
Your manager realizes that she has given you the wrong amount for the 
expenditures at Kinkos. Edit the figure and add the information she has 
provided for the month of April.  
 

1. Click once on cell C4 to select it. 

2. Type “33.50” in cell C4 and press [ Enter ]. 

3. Click the mouse button to select cell A6. 

4. The active cell is now A6. Type “April” in cell A6 and press [ Tab ] to 
move to the right to cell B6. 

5. Enter the following information in your worksheet to complete the row 
for April.  
 
When you are finished, your worksheet should look like Figure 1-12. 
 
 BJ’s:  25.25 
 
 Kinkos: 20.99 

 
Figure 1-12: Excel Worksheet through April 
 

6. Time to save your work! Click the File menu and select Save.  
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Lesson 2 

Editing Your Worksheet 
 
In this lesson we'll… 

 Explore how the mouse pointer changes in Excel 
 Learn about ranges of data. 
 Use a terrific feature called AutoFill to fill cells with 

a series of data. 
 Learn to move and copy data into other cells. 
 Insert and delete rows and columns. 
 Explore the Undo and Redo commands. 
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2-A: Excel Mouse Pointers 

As with other Microsoft programs, the shape of the pointer changes as you are 
working in Excel.  

Each pointer shape is communicating something about how Excel is working. 
The shape of the pointer when you click and drag a cell will greatly influence the 
results of the click and drag. The following table includes a description of each 
of the pointer shapes you may encounter in Excel.  

Shape Implication Action 

 
The default pointer shape. Moves cell pointer or 

selects a range of 
cells. 

 

Appears when the pointer is on a 
border (column, row, or window). 
When adjusting row height, the arrows 
point up and down. When adjusting 
column width, the arrows point right to 
left. 

Adjusts the column 
width, row height, or 
window size. 

 
Appears when you are editing the 
contents of a cell. 

Moves the insertion 
point within the cell. 

 Appears when you are at the "fill 
corner" of a cell or range of cells. 

AutoFills other cells 
with similar 
information. 

 

Appears when you are pointing to the 
border of a cell.  

Moves the selected 
cell to a new 
location. 

 
 

 Excel’s Text to Speech feature allows you to audibly verify your 
data.  Use the Text to Speech Toolbar (Click Customize Quick-
Access Toolbar, More Commands, Speak Cells, and Add) to 
display the Text to Speech Toolbar.  

   
 Select the cells you want to verify.  Click the Speak Cells icon to 

have Excel read back each cell in your selection.  You can turn 
off this feature with the Stop Speaking icon. 
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2-B: Working with Ranges 
 
What is a range? 
A range is a rectangular group of adjacent cells in a worksheet. A range is the selected 
area that will be affected by the next command.  
 
To select a range of cells: 
 
 With the mouse, point to the center of the cell in one corner of the 

range (the mouse will look like an empty cross (     ), then do one of the 
following: 
 

• Press and hold the mouse button while dragging to the 
opposite corner of the range; release the mouse button. 

• Press and hold the [Shift] key and click on the opposite 
corner of the range to select all cells in between. 

• Press and hold the [Shift] key and press the arrow keys to 
highlight the range. 

Selecting a range of data can be helpful when working in an Excel 
worksheet. Selecting ranges allow you to do the following that we will 
explore in this class: 

 
• Apply formatting to a group of cells in a range (instead of 

formatting one cell at a time). 
• Copy/Delete multiple cells at once. 
• Minimize the area in which data will be entered. 
• Select an area to use text-to-speech. 

 
Referencing a Range 
A range is referenced by the first cell reference, [Column Letter, Row Number]:” and 
then the last cell reference. 
 
Some examples of ranges are selected in 
Figure 2-1:  

• A1:D2 
• A5:A10 
• C7:F12 

 
 
 
 
 
 

Figure 2-1: Ranges 
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Figure 2-2: AutoFill Copy Example 
 

Figure 2–3: AutoFill Series Example 
 

2-C: Using the AutoFill Feature 
 
Using AutoFill you can quickly copy the contents of one cell (text, numbers and formulas) 
into an adjoining cell or complete a series from a pattern you have established. 

The Fill Handle is the box at the lower-right corner of a cell or range that you can use to 
activate Excel’s Auto Fill feature.  

To use AutoFill to copy the contents of one cell: 
 

1. Click anywhere inside the cell that you want to copy to select it. 

2. Rest the mouse pointer on the Fill Handle at the lower-right corner of 
the selected cell. The mouse pointer will 
change to a solid cross (  ). 

3. Once the pointer has changed to a solid 
cross, click and hold the mouse button 
down and drag the Fill Handle to the 
adjoining cell that you want to copy into 
(You can copy down or across). 

4. Release the mouse button. Excel fills the cell 
with the data. 

 
To use AutoFill to create a series: 

Define your own series by entering at least two values from which Excel can 
compute the size of the increase or decrease from one entry to the next.  
 
For example, to create a series beginning with 5 and increasing by 5’s, enter 5 
and 10. Select those cells and then AutoFill. Excel will create the series 5, 10, 15, 
20 … 

 
1. Highlight the two (or more) adjoining cells that 

establish the pattern of your series. 

2. Rest the mouse pointer on the Fill Handle at the 
lower-right corner of the selection. The mouse 
pointer will change to a solid cross (  ). 

3. Once the pointer has changed to a solid cross, 
click and hold the mouse button down to drag 
the Fill Handle as far as you want cells filled with 
the data. 

4. Release the mouse button. Excel fills the cells in 
series, continuing the established pattern. 

 
Excel also Automatically fills series that it recognizes, for 
example Months of the year, days of the week, or dates. 
For date entries, Excel will also automatically adjust the entries as it fills to create a series. For 
example, 1/21/2005 will be followed by 1/22/2005, 1/23/2005 and so on. 
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Figure 2-5: Fill Handle 
 

 Activity 2 - 1 
Using AutoFill to Complete a Series 

 
Scenario: 
You are ready to enter the expense data for the remaining months of the year. 
Use AutoFill to quickly enter the months May through December.  
 

1. Highlight to select cells A4 through A6. The range which establishes the 
pattern of your series is now selected (Refer to Figure 2-4). 

 

 
Figure 2-4: AutoFill Series Established 
  

2. Rest the mouse pointer on the Fill Handle at the lower-right corner of 
the selection. The mouse pointer will change to a solid cross (  ). 

 
3. Once the pointer has changed to a solid cross, click and hold the mouse 

button down to drag the Fill Handle to cell A14 (Refer to Figure 2-5). 
 

4. Release the mouse button. Excel fills the months May through 
December in cells A7 through A14. 
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 Activity 2 - 2 
Practice selecting a Range of Cells 

 
Scenario: 
Sometimes it is easier to select the range before entering data. This is especially useful 
if you are familiar with entering numbers with a keypad. 
 
Select the proper range and enter the expense data for BJ’s for May through December. 
 

1. With the mouse, point to the center of cell B7 and press and hold the mouse 
button while dragging down through cell B14. 
 

2. Release the mouse button in cell B14 and the range B7:B14 will be highlighted 
(Refer to Figure 2-6). 
 

 
Figure 2-6: Range B7:B14 
 

3. Without clicking the mouse, type “30.50”. Data is entered in cell B7, the 
first cell in the selected range. 
 

4. Press [Tab] to move directly down to cell B8. 
  

5. Without clicking the mouse, type “10.75”. Data is 
entered in cell B8, the next cell in the range. 

  

6. Press [Tab] to move directly down to cell B9. 
 

7. Continue this process of data entry for the months 
July through December according to the expense 
data listed below.  
 

• July = 0.00 
• August = 0.00 
• September = 97.60 
• October = 45.25 
• November = 20.75 
• December = 38.15 

   Figure 2-7: Range B7:B14 Complete 
 
When you are finished, your worksheet should look like Figure 2-7. 
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2-D: More Selecting Data 
 
 
Selecting (Highlighting) an entire Row, Column, or Sheet  
 

• To select an entire Row, click on the 
Row Heading (the number at the 
left of the row). 

 
 
 
 

                         
 

 
 

 Figure 2-8: Select a Row 
 
 

• To select an entire Column, click on the 
Column Heading (the letter at the top of the 
column).  

 
 
 
 
 
 

 
 
 

   Figure 2-9: Select a Column 
 

 
 

• To select an entire sheet, click in the 
gray box to left of Column Heading A 
and above Row Heading 1. 

 
 

 
 
 
 

Figure 2-10: Select Entire Sheet 
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Adjacent vs. Non-adjacent Ranges 
 
In Excel, you can select more than one range at the same time.  However, those 
ranges do not have to be adjacent.  To select a group of separate (non-
adjacent) ranges that you want to affect at the same time: 
 

• Windows: Highlight the first continuous range as you did above, then 
hold down the [Control] key and select addition non-adjacent cells and 
cell ranges, these must be non-adjacent cells.  

 
• Macintosh: Highlight the first continuous range as you did above, then 

hold down the [Command] key and select additional non-adjacent cells 
and cell ranges.  

 
 

 

2-E: Moving, Copying, Cutting and Pasting Data 
 
Occasionally, you may need to transfer data from one location in a worksheet 
to another; Microsoft Excel offers a few methods for doing this.  Moving data 
can save you time.  For instance, if you want the data in a different place, rather 
than delete from its original location and retype it in the new location, you can 
simply move it.   
 
The most convenient way to move data short distances is to drag and drop the 
data from one location to another. 
 
To move data using the Drag-and-Drop method: 
 

1. Click the mouse to select (highlight) the item(s) you want to 
move. 

2. Once the selection is highlighted, release the mouse button. 

3. Move the mouse pointer over the border of the selection. The 

mouse pointer changes to a four-headed arrow (  ) 

4. Press and hold the mouse button and drag the selection to its 
new location. As you move, an outline follows showing the shape 
of the selection. 

5. When it covers the area you want to fill, release the mouse 
button. 
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Copying, Cutting, and Pasting Data 
 
Moving data is one method for getting data from one area of your worksheet to 
another. Two other options available in Excel are (1) copy and paste and (2)cut 
and paste. You can paste the data into another area in the same worksheet or 
paste into a completely different worksheet. 

 

When you copy and paste data, Excel copies the cell contents and pastes them 
in another location. When you cut and paste data, Excel moves the data from 
its current location to its new location. 

 
 Excel surrounds the selected area to be copied (or cut) with a moving 

dotted line called a marquee. To deselect data (and stop the marquee), hit 
the escape key. 

 
 
 
 
 
To copy and paste data: 
 

1. Select the data to be copied. 

2. Once the data is selected, use one of the following methods to copy 
and paste it. 

• Use the Home Toolbar:   
 

Click the Copy button; select the destination, then click the Paste 
button. 
 

• Use Keyboard Shortcuts: 
 
Press [Ctrl] C to copy; select the destination, then press [Ctrl] V to 
paste. 

 
• Use the Keyboard: 

 
Point to the border of the cell range while pressing the [Ctrl] key, 
drag to new location, release mouse button and then [Ctrl] key. 
 

• Use the Fill Handle: 
 
Drag the Fill Handle on the selection to the adjacent cells to 
which you want to copy the data and release the mouse button. 
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To cut and paste data: 
 

1. Select the data to be cut. 
 

2. Once the data is cut, use any of the following methods to cut and 
paste it. 

• Use the Home Toolbar:   
 
Click the Cut button; select the destination, then click the 
Paste button. 

 
• Use Keyboard Shortcuts: 

 
Press [Ctrl] X to cut; select the destination, then press [Ctrl] V 
to paste. 
 

      When you copy or cut cells, Excel automatically adjusts all relative 
references, such as formulas. 
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 Activity 2 - 3 
Moving and Copy and Pasting Data 

 
Scenario: 
 
The expense data for the months of May through December was for Kinkos not 
BJ’s. Use the Drag and Drop method to move the data to the proper column. 
 

1. Select cells B7:B14 (Refer to Figure 2-11). 

 
Figure 2-11: Selected Range B7:B14 
 
2. Once the range is selected, release the mouse button. 

 
3. Position the mouse pointer over a border of the selection. The 

mouse pointer changes to a four-headed arrow. 
 

4. Press and hold the mouse button and drag the selection to Column 
C so that it fills the range C7:C14. An outline in the shape of the 
range will appear in this new location (Refer to Figure 2-12). 

 

 
Figure 2-12: Drag-and-Drop      
 
5. Once the outline covers the range C7:C14, 

release the mouse button. Excel moves the 
expense totals from B7:B14 to C7:14 as seen 
in Figure 2-13. 

Figure 2-13: Moved Data 
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Scenario: 
At the end of the year you will need separate totals for each vendor. Copy and 
paste the word Totals. 
 

1. Click in cell D2 to select it. 

2. Select Home Menu > Copy  from the Menu Bar.  
 

3. Click in cell A16 to select it. 

4. Select Home Menu > Paste  from the Menu Bar. Your updated 
worksheet should look like Figure 2-14. 

 

 
Figure 2-14: Copy and Paste Data 
 

  



 

26  Introduction to Excel: Part 1 

2-F: Cells (clearing, inserting, deleting) 
   
Clearing Data in Cells 
To erase data from a cell without deleting the cell you must select use the Clear 
command. There are four options: All, Formats, Contents, and Comments. 
 
 
To clear data: 

1. Highlight the cell, range of cells, column, or row you want to clear. 
2. In the Home Tab, select Editing > Clear. 
3. Select the appropriate option as described in the table below. 

 

All Clears the data, formatting, and any notes in the cell. 
This will result in a blank cell with a GENERAL format.  

Formats Clears the format but leaves the data and notes intact. 
The selected cells will return to a GENERAL format.  

Contents  Clears the data and any formula from the selected cells 
but leaves the formatting and the notes.  

Comments  Clears the notes and leaves the formatting and the data 
intact.  

 

Pasting Between Existing Cells in a Worksheet (Inserting) 

Excel will allow you to paste a cell or a range of cells between existing cells.  
 

1. Select and copy (or cut) the cells you want inserted between existing cells. 
 

2. Right click and use Insert > Copied Cells.  
 
Respond to the dialog box by selecting the direction to move cells to 
allow insertion.  
 

     When pasting a range of cells, it is a good idea to only select the upper-
left hand cell of the range you want to paste in. If you choose to 
highlight the entire paste area, the range must be the same size and 
shape of your copy/cut area. 

 
Deleting Cells 
 

1. Select the cell(s) you want to delete. 
2. Right click and use Edit > Delete.  

Respond to the dialog box by selecting the direction to shift cells 
to allow for the deletion.  
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2-G: Rows and Columns (inserting, deleting) 
 
Sometimes when working with data you realize you've missed some 
information.  Now that you are able to navigate successfully in Excel, you could 
move the data around to make room, but that's not always ideal. There is an 
easier way to complete this task. You can insert and delete Rows and Columns 
without having to move existing data. 
 

Inserting Columns 

Inserting a Column creates a blank column and moves all columns one column 
to the right, including the highlighted column. Select several contiguous 
columns to insert the same number of columns. 

To insert a column: 

1. Click on the Column Header to the right of the location where 
you wish to insert a new column. 

2. Right Click, and select Insert. 

 

Inserting Rows 

Inserting a Row creates a blank row and moves all rows down one row, 
including the highlighted row. Select several contiguous rows to insert the 
same number of rows. 

To insert a row: 

1. Click on the Row Header below the location where you wish to 
insert a new row. 

2. Right Click, and select Insert. 

 

Deleting Columns and Rows 

Deleting a column removes the selected column or row. The columns to the 
right of the deleted column then shift left.  

Deleting a row removes the selected row. The rows below the deleted row shift 
up. 

To delete a column or row: 

1. Click on the Column or Row Header you wish to delete. 

2. Right Click, and select Delete. 

 

 

     You can also use the Cells section of the Home tab to 
insert or delete rows and columns. 
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 Activity 2 - 4 
Insert a Column and Enter Data 

 
Scenario: 
You need to add a column to record expenses for Star Market. Insert a column 
between Kinkos and Totals for Star Market and update the expenses. 
 

1. Click on the Column Header D to select Column D. 

2. Right Click, and select Insert. 
 

Excel inserts a new column to the left. As seen in Figure 2-15, the Totals 
column is now moved to Column E. 
 

 
Figure 2-15: Insert Column 
 
3. Click in cell D2 to select it. 

4. Type “Star Market”. 

5. Click in cell D13 to select it. 

6. Type “6.99” 

7. Update your worksheet with the new 
data for BJ’s for the months of May 
through December so that your 
worksheet looks like Figure 2-16.  
 
 
 
      

   

 

 

 
 
          Figure 2-16: Updated Worksheet 
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2-H: Rows and Columns (resizing) 

Resizing Columns 

In many situations, a cell will be too wide or too narrow to properly display the 
data it contains. In these situations, you can resize the cell’s column so that the 
data will be displayed correctly. 

There are three ways to specify the column width in Excel. 

1. Drag the Double-Arrow  

Position the pointer on the Column Header division line. The 
mouse pointer will change to a double-arrow indicating that you 
can now resize the column. Drag left or right to resize the column. 
Release the mouse when the column is at the width you want. 

 

2. Format the Column Width 

Select the column(s) you want to resize. Right Click. Select 
Column Width, and then type the value that you want. 

 

3. AutoFit the Column Width 

Select the column(s) you want to resize. On the Home tab, in 
the Cells group, click Format. Under Cell Size, click AutoFit 
Column Width. 

 

Resizing Rows 

To resize a row to a new height in Excel: 

1. Drag the Double-Arrow  

Position the pointer on the Column Row division line between 
the row to be resized and the one directly below it. The mouse 
pointer will change to a double-arrow indicating that you can 
now resize the row. Drag up or down to resize the row. Release 
the mouse when the row is at the height you want. 
 

2. Format the Row Height 

Select the row(s) you want to resize. Right Click. Select Row 
Height, and then type the value that you want. 
 

3. AutoFit the Row Height 

Select the row(s) you want to resize. On the Home tab, in 
the Cells group, click Format. Under Cell Size, click AutoFit Row 
Height. 

 A shortcut to AutoFit a row is to double-click on the dividing line to 
 the right of the column header or below the row number header.  
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 Activity 2 - 7 
Resizing Columns 

 
Scenario: 
A couple of the columns in the worksheet are too narrow to fit the data. You 
will need to resize the width of Columns A and D so that the text “September” 
and “Star Market” will fit. 
 

1. Click on the Column Header A to select Column A. 

2. On the Home tab, in the Cells group, click Format. Under Cell Size, 
click AutoFit Column Width. Browse down the column to notice that 
“September” now fits completely in its cell. 

3. Double click the dividing line between Column D and E. Notice that 
“Star Market” now fits completely in its cell. 

 

 

 

 

 
 
 
 

 UNDO and REDO 
 
Undo allows you to reverse one or more of your most 
recent actions.   

• Once you use the Undo feature, the Redo feature 
becomes available.  

• The Redo feature allows you to restore the 
results of the command or action you reversed 
with the Undo feature.  

• Both features can be accessed using the 
Standard toolbar or the Edit menu.  

Multiple Actions 
You can also undo or redo multiple actions using the drop-down arrow next 
to the Undo or Redo buttons on the Standard toolbar.  
 

UNDO REDO 
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Lesson 3 

Using the AutoSum feature 
 
In this lesson we'll… 

 Discuss formulas and functions 
 Learn about the AutoSum feature 
 Use AutoFill to copy a function 
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3-A: Formulas and Functions Overview 

Formula 
A formula is a set of instructions that you enter in a cell to perform calculations 
on values entered into the cells of a worksheet. Formulas consist of the 
addresses of the cells containing the values and the appropriate mathematical 
operators.  

All formulas include three key elements: 
 

1. An equal sign ( = ) to begin the formula. 
2. The cell references or values you wish to 

include in the calculation. 
3. The mathematical operator(s) to be used in 

the calculation. 

 
 
Function 
A function is a built-in Excel formula. You can use functions to simplify the 
process of entering formulas. For example, if you wanted to add the values of 
cells D1 through D10, you would type the formula 
“=D1+D2+D3+D4+D5+D6+D7+D8+D9+D10”. A shorter way would be to use the SUM 
function and simply type “=SUM(D1:D10)”. 
 
All functions contain the same syntax: 
 

1. An equal sign ( = ) at the beginning. 
2. The Function name follows next. 
3. The Arguments (the cell references to be 

used in the calculation enclosed in 
parentheses) come last. 
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3-B: AutoSum Feature 
 

Excel’s AutoSum tool allows you to quickly enter several commonly used 
functions without needing to know or type any function syntax. 
 

 To calculate a sum using AutoSum: 
 
1. Click on the cell into which you want the result to appear. 

2. Click the AutoSum button on the Standard Toolbar.  
 

3. Excel will highlight a range that it assumes you would like to sum. 
 
1. If Excel has chosen the correct range, press [Enter]. 

 
2. If Excel has chosen the incorrect range, simply click and highlight 

the correct range, and then press [Enter]. 
 
When reselecting a range, be careful not to select the cell that 
contains the function! 
 

4. Excel calculates and enters the sum. 
 
 
Functions available through the AutoSum feature: 
 

Function Example Description 

Sum =SUM(A4:A10) Adds the values in cells A4 
through A10. 

Average =AVERAGE(B1:B4) Calculates the mean average of 
the values in cells B1 through B4. 

Minimum =MIN(C5:C20) Finds the minimum value of the 
values in cells C5 through C20. 

Maximum =MAX(D1:D10) Finds the maximum value of the 
values in cells D1 through D10. 

Count =COUNT(A2:A18) Finds the number of numeric 
entries in cells A2 through A18. 
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Calculating an Average, Minimum, Maximum or Count 
 

1. Click on the cell into which you want the calculation result to display. 
 

Click on the downward arrow next to the AutoSum button  to 
select  
 
Average, Minimum, Maximum or Count. 
 

2. Excel will highlight a range that it assumes you would like to perform 
the calculation on. 
 
1. If Excel has chosen the correct range, press [Enter]. 

 
2. If Excel has chosen the incorrect range, simply click and highlight 

the correct range, and then press [Enter]. 
 
When reselecting a range, be careful not to select the cell that 
contains the function! 
 

3. Excel calculates and enters the result. 
 
 
Use AutoFill to copy a formula: 
 

Once you've created a formula, you can copy it by using the AutoFill 
feature: 
 

1. Select the cell with the formula you wish to copy. 

2. Rest the mouse pointer on the Fill Handle at the lower-right 
corner of the selected cell. The mouse pointer will change to a 
solid cross (  ). 

3. Once the pointer has changed to a solid cross, click and hold the 
mouse button down and drag the Fill Handle to the adjoining 
cell(s) that you want to copy the formula into. 

4. Release the mouse button. Excel fills the cell(s) with the formula 
while also updating the cell references accordingly! 
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 Activity 3 - 1 
Calculate Sums Using AutoSum 

 
Scenario: 
You have finished entering all the expense data for the year. You are now ready 
to calculate the totals for each vendor in each of the respective columns. You 
will use AutoSum and AutoFill to accomplish this task. 
 

1. Click in cell B16 to select it. 

2. Click the AutoSum button on the Standard Toolbar. 

3. Excel highlights the range B3:B15 (Refer to Figure 3-1).  Since this is 
correct, press [Enter]. 

 

 
Figure 3-1: AutoSum BJ’s 

 
4. Excel enters the total for BJ’s at 402.01.  

 
 

5. Repeat these steps to use AutoSum to 
calculate the totals for Kinkos and Star 
Market. 

 
NOTE:  Be careful when calculating the 
sum for Star Market – Excel might not 
always assume the correct cell range… 

 
6. When you are finished, your worksheet 

should look similar to Figure 3-2. 
 
 

      Figure 3-2: Totals 
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 Activity 3 – 2 
Calculate Totals for each month using AutoSum and AutoFill 

 
Scenario: 
You are now ready to calculate the totals for each month. In this activity you will 
use AutoSum to calculate the sum for the month of January. You will then use 
the AutoFill feature to calculate the totals for the remaining months. 

 

1. Click in cell E3 to select it. 
2. Click the AutoSum button on the Standard Toolbar. 

 

 
Figure 3-3: January Totals 

3. Press [Enter]. Excel performs the calculation and your total for January is 
entered as 161. 

4. Click cell E3 to select it (this is the cell containing the formula you want to 
copy). 

5. Rest the mouse pointer on the Fill Handle at the lower-right corner of the 
selected cell. The mouse pointer will change to a solid cross (  ).  

6. Once the pointer has 
changed to a solid cross, 
click and hold the mouse 
button down to drag the 
Fill Handle to cell E14.  

7. Release the mouse 
button. Excel calculates 
and enters the totals for 
the remaining months! 
Your worksheet should 
now look like Figure 3-4. 

 
 
 

F
i
g
u
r
e
 3-4: AutoFill Sum 
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 CHALLENGE Activity 3 – 1  
Calculate Yearly Average Cost for each Vendor   

 
Scenario: 
You are now interested in determining what the average yearly cost for each 
Vendor. 
 

1. Click in cell A17 to select it. 

2. Type: Average 

3. Click in cell B17 to select it. 

4. Click the downward arrow next to the AutoSum button on the 
Toolbar and select Average. 

5. Use your mouse to select the correct range (B3:B14). 

6. Press [Enter].  
 
Excel performs the calculation and displays the average for B.J.s in 
cell B17. 

7. In cell C17, practice calculating and average for Kinkos.  Except this 
time edit the range reference in the Formula Bar instead of using 
your mouse to select the correct range. 
 
 

 CHALLENGE Activity 3 – 2 
Calculate Yearly Highest Cost for each Vendor  

 
Working in row 18, use the AutoSum feature to calculate the highest amount 
you paid during the year to BJs and Kinkos. 
 
 
 
 
 

 CHALLENGE Activity 3 – 3 
Calculate Yearly Lowest Cost for each Vendor  

 
 
Working in row 19, use the AutoSum feature to calculate the lowest amount you 
paid during the year to BJs and Kinkos. 
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For more information on Excel, the following sources are recommended: 
 

• Try the Help menu built into Microsoft Excel. 
 

•   Take free, online Excel training courses:  
 http://office.microsoft.com/training 
 

Once at the above Web page, under the Office 2010 Training section, select Excel 
2010. “Get to know Excel 2010: Create your first spreadsheet” and “How to create a 
basic chart in Excel 2010” are two examples you will find in the Excel Courses listing. 
 
Windows users at Boston College may also use Microsoft eLearning Modules 
For details, view: http://www.bc.edu/mselearning  
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