Skip to main content

Secondary navigation:

Information Technology Services

Using iCal on Snow Leopard (Mac OS X 10.6) or higher

Mail and iCal use with Exchange is only supported on Snow Leopard (Mac OS X 10.6) or higher. You cannot use iCal or Mail with Exchange in earlier versions of Mac OS X.

Calendaring Basics

Learn the basics of using iCal, including how to view your calendar, create appointments, set reminders, and reserve resources.


Working With Shared Calendars

Learn about giving others permission to a calendar and working with shared calendars.